1. Home
  2. Using Genstat
  3. The Genstat Windows Interface

The Genstat Windows Interface

The Genstat Windows interface is based on a Multiple Document Interface (MDI) format using menus, windows, and dialogs to provide an easy interface to the Genstat statistical language.

This uses multiple text windows to display Genstat output and prepare Genstat commands and data for input. The contents of a text window can be scrolled using the scroll bars or the keyboard navigation keys (PageUp, PageDown etc.) and edited using menu bar functions to cut, copy, and paste text. Edit functions operate on the currently active window, indicated by a highlighted title bar. Text files can be loaded into text windows and the contents of a window can be saved to a file. Any text window can be used to send commands to Genstat, via the Run command located on the menu bar. In addition, menus are provided for many common tasks, such as loading and saving data, spreadsheet data entry or editing, graphical output, summary statistics, analysis of variance and regression. You can switch at any time between menu and command based approaches, enabling use of the command language to provide any functions not explicitly available from a menu. This help information includes a complete description of the syntax of every Genstat directive and procedure as a reference for the command language.

Genstat always starts with two text windows, the Output window and the Input Log. Using the File menu, additional windows can be opened at any time for editing Genstat programs or data.

Genstat can be started by double-clicking on file icons in File Manager or Windows Explorer, for file types (e.g. *.GEN) associated with Genstat.EXE. Once running, Genstat will also accept files dragged and dropped onto it. Text files will be opened in text windows, and spreadsheet files (*.GSH, *.XLS, etc.) will be opened as spreadsheets.

Output Window

A window which displays the output from Genstat. This window is updated asynchronously with results as they become available from the Genstat Server. Output is displayed in Rich Text Format (RTF), however, you can change to plain text output using the Output item on the View menu. Output can be saved to a file or printed using the File or Print menus. All Genstat output is displayed in this window; thus, it can only be closed by terminating Genstat for Windows. You can clear the Output window by using Delete from the Edit menu.

Input Log

A window which contains a record of all the commands generated by menu selections and sent to Genstat. This window cannot be closed and is initially set to be read-only, but you may wish to keep it minimized if you do work mainly from the menus provided. You can clear the Input Log using the Delete command from the Edit menu.

Event Log

The Event Log provides a log of events within a Genstat session. An event is an action that occurs during the Genstat session such as a fault or warning message, clearing of output or restarting the server. For faults and warnings you can view full details from the Event log.

The first fault or warning message in each set of commands sent to Genstat, from a menu or text window, will generate a pop-up warning, reminding you to check the messages in the Output window or Event Log.

Updated on July 24, 2018

Was this article helpful?