Edit Menu Commands (Spreadsheet)

The Edit menu can be used on spreadsheets, and contains options for editing, searching for, and manipulating spreadsheet data. The Edit menu commands can also be used with text windows, but the dialog that opens may have different options enabled.

Undo

Re-applies the last action that was undone. An undo list is maintained for each open spreadsheet. You can set the maximum number of undo operations using the Tools | Spreadsheet Options | Sheets tab.

Redo

Reverses the last Undo operation. By default, this option is disabled, however, you can activate this by selecting the Enable redo option on the Tools | Spreadsheet Options | General tab. Note that activating the Redo facility can considerably increase the memory requirements if using large spreadsheets.

Cut

Removes values from selected rows, columns or range to the Clipboard. The cell contents are replaced by missing values, unless the Auto delete on cut option has been selected on the Tools | Spreadsheet Options | Conversions tab. If there is no selection, the Cut operation will operate on the current cell, copying its value to the Clipboard and will replace it by a missing value.

Copy

Copies values from selected rows, columns or range to the Clipboard. If there is no selection, the Copy operation will copy the value of the current cell to the Clipboard.

Paste

Pastes a copy of the Clipboard contents into the spreadsheet. If there is no selection on the spreadsheet, the Clipboard values are entered starting at the current cell, filling the cells to the right and below the current cell, up to the size of the Clipboard data. By default, the spreadsheet will be extended with new rows and columns if required, however, you can prevent this by disabling the Auto extend on pasting cells option has been selected on the Tools | Spreadsheet Options | Conversions tab.

For selected rows, columns or a range, the Clipboard contents are copied into the selected cells. If the size of the data on the Clipboard is larger than the selection, in either dimension, the data will be truncated at the selection boundary. Similarly, if the size of the Clipboard data is smaller than the selection, the data will be repeated to fill the selection.

Paste Special

Pastes a copy of the Clipboard contents into the spreadsheet using options specified in the Paste Special dialog.

If you are pasting into a text window a dialog with different options will be used.

Copy Special

Places a copy of the spreadsheet onto the Clipboard contents using a special format:

Text The complete spreadsheet as tab delimited text.
RTF Table The spreadsheet as a RTF (Rich Text Format) table.
HTML Table The spreadsheet as a HTML (Hypertext Markup Language) table.
Rectangle The selected cells as tab delimited text.

The RTF/HTML options are controlled by the Save to Rich Text Format/HTML Options dialog.

You can also copy a text window such as the input log. This opens a dialog that enables you to insert tabs to split the text.

Column

Provides options for cutting, copying and pasting spreadsheet columns. You can also duplicate columns and view and edit a column’s properties.

Rectangle

Provides facilities for working with a rectangle (a block of text defined by starting and ending lines and columns) in a text edit window to Cut, Copy, Paste, DeleteInsert or Fill the rectangle.

Copy Filename

Lets you copy the filename of the current text window or spreadsheet including the full path details to the Clipboard. When the filename is copied the backslash (‘/’) character is used to separate directory names so that they can be used for commands such as the OPEN and SPLOAD directives.

Delete

Deletes selected rows, columns, cells, or the current cell, from the spreadsheet, replacing their contents with missing values. Use this menu item as an alternative to Cut if you do not want to alter the Clipboard contents.

Select All

Selects all cells in the current spreadsheet.

Remove White Space

Open the Remove White Space dialog to delete blank lines or white space at the end of lines.

Check Line Lengths

Open the Check Line Lengths dialog to wrap or bookmark long lines.

Find

Finds text within a spreadsheet. If a selection (row/column/range) has been made the search may be restricted to within the selected cells. The direction of the search is column by column, i.e. the search proceeds down a column until it reaches the last cell and then starts on the first cell on the next column.

Find Next

Find the next occurrence of the search text in the spreadsheet.

Replace

Replace some text in a spreadsheet cell. If a selection (row/column/range) has been made the replace operation may be restricted to within the selected cells.

Goto

Lets you go to a specified cell. You can also set the active cell by clicking with the left mouse button. If the cell that you want to edit is not visible you can use the scroll bars to locate it.

Go Back

Go back to the previous cell (up to 5 locations are recorded). On reaching the end of the location stack, it returns to the position at the top of the stack (i.e. that cell from which the Go back process was started).

Bookmark

Opens the Bookmark menu to place bookmarks or notes in the current cell, to add notes or jump to previous defined bookmarks. Bookmarked cells are shown in the spreadsheet by a background colour which you can change as required.

Change Case

Change the case of text in the selected spreadsheet cells.

Delete Current Row

Deletes the current line of text from a window or the current row of a spreadsheet.

Repeat Current Row

Duplicates the current line of text from a window or the current row of a spreadsheet.

See also

Updated on April 1, 2022

Was this article helpful?