1. Home
  2. Bar Chart

Bar Chart

Select menu: Graphics | Bar Chart

Use this to specify data for a bar chart.

  1. After you have imported your data, from the menu select 
    Graphics | Bar Chart.
  2. Fill in the fields as required then click Run.

You can include error bars in a single bar chart or when several bar charts are plotted alongside each other using the Error bar tab. These take the form of a horizontal line joined by a vertical line of the specified height, above and below each bar. You can set additional options and axis settings by clicking the Options, Axis and Frame tabs.

Data arrangement

Specifies the form of the data to be used in the plot. The data can be supplied as Variate(s) defining heights or Summary table(s).

Variate(s) defining heights

Specifies the data containing the heights for each bar to be displayed in the bar chart. If several variates are supplied they must contain the same number of values.The representation of the multiple bar charts can then be set in the Options tab where they can either be displayed alongside each other or stacked. Double-click a name in the Available data field to copy it across or type the name. You can transfer multiple selections from Available data by holding the Ctrl key on your keyboard while selecting items, then click to move them all across in one action.

Summary table(s)

Specifies summary tables containing the heights for each bar to be displayed in the bar chart. You can supply one or more one-way tables or a single two-way table. If several one-way tables are supplied then the tables must all be classified using the same factor. For a two-way table or multiple one-way tables the representation of the multiple bar charts can then be set in the Options tab where they can either be displayed alongside each other or stacked. Double-click a name in the Available data field to copy
it across or type the name. You can transfer multiple selections from Available data by holding the Ctrl key on your keyboard while selecting items, then click to move them
all across in one action.

Create summary table

This opens a menu which has two options for creating tables with 1 or 2 classifying factors.

Entering the data values into a spreadsheet This opens the Create Table using Spreadsheet dialog where you can enter values for the table into a spreadsheet.
Form a summary table using grouping factors This opens the Create 1 or 2 way Table using Groups dialog where you can choose an existing variate and summary to create a table from.

Factor for x-axis

When a two-way table has been specified within the summary tables field a list will appear containing the names of the two classifying factors associated with that table.
This option can be used to select which of the two classifying factors will be used to specify the categories displayed on the x-axis. The groupings for the other
classifying factor will be displayed using different colour bars within each of the categories on the x-axis.

Available data

This lists data structures appropriate to the current input field. It lists either summary tables, or variates for specifying the data. The contents will change as you move from one field to the next. Double-click a name to copy it to the current input field or type the name.

Labels for bars

Specifies a text containing labels to use for each of the bars supplied by the data variates. Double-click a name in the Available data field or click to copy
it across. You can also type the name.

Action buttons

Run Produce the graph.
Cancel Close the dialog without further changes.
Defaults Reset options to their default settings.

Action Icons

Pin Controls whether to keep the dialog open when you click Run. When the pin is down  the dialog will remain open, otherwise when the pin is up  the dialog will close.
Restore Restore names into edit fields and default settings.
Clear Clear all fields and list boxes.
Help Open the Help topic for this dialog.

See also

Updated on January 21, 2022

Was this article helpful?