Tools Menu Commands


Themes

This menu allows Genstat themes to be selected, saved or loaded. A theme is stored in a .GTH file and controls the look and feel of the client windows. It packages together options that can be modified with the fonts and colours and spreadsheet appearance options. Genstat comes with a set of built-in themes (system themes), but you can modify or create your own themes with these menus. Selecting a theme changes all the look and feel options together to that storted in the theme file, and so are a fast way of switching between different sets of look and feel options.

The Select menu gives a list of the theme files in the system, user or current directories and allows you to choose one of these as the current theme.

The Save menu allows you to save the current look and feel to a theme file in either the system, user or current directory.

The Load menu uses the file open dialog to read in a theme file from any directory, and will offer to store it in either the system or user theme directories.

Syntax Only

When selected the command generation mode is enabled. In this mode, menus send generated commands only to the Input Log, and not to Genstat. This allows the menus to be used to generate a Genstat program which may be saved to a file or edited before sending to Genstat using the Run menu.

Syntax Highlighting

When selected, the Genstat command language will have the command words and symbols highlighted in different colours. You can set the colours for the different attributes of the command language within the Fonts and Colours section of the Options menu.

Options

Sets various options for Genstat, including general, text editor, audit trail, save settings, fonts and colours date format, data space, graphics, and menus.

Spreadsheet Options

Specifies various control parameters for spreadsheet windows. Click here for further details.

Graphics Environments

Lets you select or create a new graphics environment files for your session. A graphics environment file contains commands that specify exactly how a graph is produced. It controls aspects like whether or not boxes are drawn around the plots, the display of the key, and the styles and the colours of outlines for graphs such as histograms or shade plots.

Customize Toolbar

Lets you control the appearance of the toolbar.

Working Directory

This sets the current working directory, which provides the default path for file menus.

Procedure Libraries

The following facilities are available for procedure libraries:

  • Attach for attaching procedure libraries.
  • Build for creating or modifying procedure libraries.
  • Display for displaying the contents of procedure libraries.

Customize User Menu

If Genstat has any add-ins attached then a menu item called User will appear on the main menu. This lets you control the appearance of the User menu.

Save Options Now

Saves the current option settings.

Save Layout

Saves the current arrangement of standard windows and icons. The Save tab of the Options menu lets you automatically save this information when you exit Genstat.

Updated on December 1, 2017

Was this article helpful?